eslint-config

An ESLint shareable configuration that used in our projects.

NPM version

Install

npm install -D @clytage-pkg/eslint-config

or with yarn

yarn add -D @clytage-pkg/eslint-config

Usage

ESLint guide: link

Example:

{
    "extends": "@clytage-pkg/eslint-config"
}

or "@clytage-pkg/eslint-config/node" for Node environment

Example (TS):

{
    "extends": "@clytage-pkg/eslint-config/typescript"
}

or "@clytage-pkg/eslint-config/typescript/node" for Node environment

Note

Requires ESLint version 8.13.0 or above

TypeScript config requires:

GitHub

View Github