eslint-config

An ESLint shareable configuration that used in our projects.

NPM version

Install

npm install -D @rahagia/eslint-config

or with yarn

yarn add -D @rahagia/eslint-config

Usage

ESLint guide: link

Example:

{
	"extends": "@rahagia/eslint-config"
}

or "@rahagia/eslint-config/node" for Node environment

Example (TS):

{
    "extends": "@rahagia/eslint-config/typescript"
}

or "@rahagia/eslint-config/typescript/node" for Node environment

Note

Requires ESLint version 8.7.0 or above

TypeScript config requires:

GitHub

View Github