npm version JavaScript Style Guide eslint

eslint-config-lodash

ESLint Shareable Config for Lodash

Usage

Install packages

Install eslint-config-lodash and its peer dependencies.

npm i -D eslint-config-lodash eslint-plugin-lodash eslint-plugin-you-dont-need-lodash-underscore

Update ESLint config

Add lodash to extends of your ESLint config

module.exports = {
  extends: [
    'lodash'
  ]
}

GitHub

View Github